Re: Nasm 0.99.00




"Frank Kotler" <fbkotler@xxxxxxxxxxx> wrote in message
news:1Jf5i.11410$xP.10082@xxxxxxxxxxx
I have attempted a "partial" (source only... and docs) release of 0.99.00
on SF. Keith and Chuck's work has "languished" long enough!

https://sourceforge.net/project/showfiles.php?group_id=6208

Your mission, should you choose to accept it, is to download the source,
attempt to compile it, test it if possible, and let us know how it goes.


when built on mingw, it seems to have problems opening files (I suspect this
is more a mingw issue though, it is ran with the CWD in the '/bin'
directory).

makefile.unx needs to be modified to work on cygwin (same issue as before).
sadly, it tries to use 'cc', which is bad on cygwin and mingw.

'rm -f *.o' also does the wrong thing, 'rm -f `find -name \*.o`' seems
better.


ndisasm fails to correctly handle REX prefixes (generates db 0x48, db 0x49,
.... instead).


opinions:

I have personally come to doubt making absolute addressing the default on
x86-64 (longer opcodes and less flexibility than with relative addressing).

mov eax, [foo]

generates the 'A1' form, which is teh long (but can refer anywhere in
memory...). it may make sense in-general to not use this form in long-mode
(in the name of saving bytes).

or such...


Best,
Frank


.



Relevant Pages

  • Re: Upgrading XP machine to run gcc
    ... I use a Windows XP operating system and never have used Linux or Unix. ... I installed the gcc components using MinGW and compiled under a DOS window. ... From what I've seen, I should be able to install an up-to-date version of gcc, I believe its 4.2.0, if I first install Cygwin. ... I think they don't supply g++, but support both cygwin and mingw with gcc/gfortran 4.3. ...
    (comp.lang.fortran)
  • Re: a wiki entry for gfortran
    ... that the gfortran folks seemed to want to send me down. ... If I'm a person who is well-advised to get a mingw 32 bit xp ... Next I tried g95. ... I renamed the Cygwin directory and all seems OK. ...
    (comp.lang.fortran)
  • Re: linking to cernlib (mathlib) with gfortran
    ... If you've got the gcc4 package under cygwin I'd imagine that the ... sources of the package I mentioned earlier should compile. ... the same to be true of minGW but I don't use it. ...
    (comp.lang.fortran)
  • Re: awka not compiling on win32
    ... I also unsuccessfully tried to compile the awka sources with MinGW. ... Personally I do believe the problem is in "libawka.a" win32 version, ... Then I re-did it with Cygwin and it worked fine. ...
    (comp.lang.awk)
  • Re: MinGW and Python
    ... -mno-cygwin) has no POSIX layer like cygwin. ... Well, you are not compiling with neither mingw, nor cygwin; ... but these aren't "endorsed" system C libraries). ... So Python itself never uses and msvcrt weirdness (well, ...
    (comp.lang.python)