Re: A problem about "vector" for c++ beginner

From: Larky Mi (LarkyMi_at_discussions.squaresoft.com)
Date: 10/22/04


Date: Fri, 22 Oct 2004 14:03:58 +0800

sorry , my used "news.yaako.com" is bad for this group.

I didn't receive other messages until today. And today I change the
"freenews.netfront.net" which is good for receiving this group,but can't
send
messages.From now on I must use both servers for this group.-_-

Thank you for everyone.

On Thu, 14 Oct 2004 18:34:17 +1000, in article <<Re: A problem about
"vector" for c++ beginner>>, "Chris \( Val \)" <chrisval@bigpond.com.au>
wrote:

--
>
>"Tabrez Iqbal" <iqbaltabrez@gmail.com> wrote in message
>news:4e1c1048.0410130902.3638b1c5@posting.google.com...
>| "Chris \( Val \)" <chrisval@bigpond.com.au> wrote in message
>news:<2t4chmF1qkrmuU1@uni-berlin.de>...
>| [snip]
>| >    std::vector<int>::size_type ix( 0 );
>| >    for( ix; ix < ivec.size(); ++ix )
>| >         // ...
>| [snip]
>|
>| why put lone ix there? why not
>| 'for( ; ix < ivec.size(); ++ix)' ? readability??
>
>Yes, imo I think it offers better readability.