in circuit emulator problem



I have a situation where after performing a halt and re-going on the
ICE I am using, one of the interrupts effectively becomes disabled,
ie.. its like it has become masked, however I have checked the
interrupt mask afterwards and its still intact.. And its only one
interrupt which is being affected. Maybe a hardware issue.. Its an
older system so who knows. Any help appreciated.

Thanks in advance,
Slavko

.



Relevant Pages

  • Re: An interrupt drived uart program dead
    ... code and data needed at interrupt time (including ... DPMI host, in which case the above locking issue is ... requirements applicable to an interrupt handler, ... HLT causes the processor to halt until it ...
    (comp.os.msdos.djgpp)
  • Re: Idle loop and CPU energy saving
    ... An enabled interrupt, NMI, or a reset will resume execution." ... such as crash on HALT or reboot on HALT. ... Nor an NMI. ... On newer, the processor itself never really halts, but instead goes into a console microcode mode. ...
    (comp.os.vms)
  • Re: Question about HPs virtual machines
    ... A proper CPU will HALT on a HALT, and not just suspect execution until ... the next interrupt... ...
    (comp.os.vms)
  • Re: Complete hangs while extracting source
    ... Sound goes into a loop with a timeframe of ... > 0.001 seconds, mouse pointer stops responding, everything goes to a halt. ... Sounds more like an interrupt issue. ...
    (freebsd-questions)
  • Re: Question about HPs virtual machines
    ... was ever tied to power reduction circuitry of any sort, ... I can recall using HALT to debug kernel mode code, ... A proper CPU will HALT on a HALT, and not just suspect execution until the next interrupt... ...
    (comp.os.vms)