Re: Calendar Issue



On Thu, 13 Nov 2008 10:04:55 +0000, RedGrittyBrick wrote:

Lew wrote:
It is also bad practice to include the type of a variable in its name.

At a guess Lew is talking about naming conventions, of which the so-
called Hungarian Notation beloved by Microsoft C programmers is the most
obnoxious, e.g

unsigned int *puiAccountTotal;

the points being that:
- it makes the variable name less readable
- if you change the variable's data type you must also change its
name, thus forcing a search&destroy mission across the entire
program.

In my example changing the variable to a signed long requires it to be
renamed to lAccountTotal.


--
martin@ | Martin Gregorie
gregorie. | Essex, UK
org |
.