plugin does not function and not compile

From: edward hage (edha_at_xs4all.nl)
Date: 01/10/04

  • Next message: somebody: "How to read SSL certificates?"
    Date: Sat, 10 Jan 2004 14:21:53 +0100
    
    

    Hello,

    I have a Linux machine and I use Netscape 7.1 which I upgraded from Mozilla.

    I downloaded j2sdj-1.4.2_02 and I have installed the plugins as followes:

    in .mozilla/plugins- directory a link to :

    edward@linux:~/.mozilla/plugins> ls -l
    totaal 0
    lrwxrwxrwx 1 root root 72 2003-11-25 23:23
    libjavaplugin_oji.so ->
    /usr/java/j2sdk1.4.2_02/jre/plugin/i386/ns610-gcc32/libjavaplugin_oji.so
    edward@linux:~/.mozilla/plugins>

    Also in the "About Plugins" in Netscape I see all my plugins, however
    the plugins do not function when loading/showing a page!!

    This problem did not always exist, and I suspect Netscape 7.1.

    However, how is it possible that "About Plugins" show the plugins !! but
    they do not function:

    Java(TM) Plug-in 1.4.2_02-b03

         File name: libjavaplugin_oji.so
         Java(TM) Plug-in 1.4.2_02

    MIME Type Description Suffixes Enabled
    application/x-java-vm Java Yes
    application/x-java-applet Java Yes
    application/x-java-applet;version=1.1 Java Yes
    application/x-java-applet;version=1.1.1 Java Yes
    application/x-java-applet;version=1.1.2 Java Yes
    application/x-java-applet;version=1.1.3 Java Yes
    application/x-java-applet;version=1.2 Java Yes
    application/x-java-applet;version=1.2.1 Java Yes
    application/x-java-applet;version=1.2.2 Java Yes
    application/x-java-applet;version=1.3 Java Yes
    application/x-java-applet;version=1.3.1 Java Yes
    application/x-java-applet;version=1.4 Java Yes
    application/x-java-applet;version=1.4.1 Java Yes
    application/x-java-applet;version=1.4.2 Java Yes
    application/x-java-applet;jpi-version=1.4.2_02 Java Yes
    application/x-java-bean Java Yes
    application/x-java-bean;version=1.1 Java Yes
    application/x-java-bean;version=1.1.1 Java Yes
    application/x-java-bean;version=1.1.2 Java Yes
    application/x-java-bean;version=1.1.3 Java Yes
    application/x-java-bean;version=1.2 Java Yes
    application/x-java-bean;version=1.2.1 Java Yes
    application/x-java-bean;version=1.2.2 Java Yes
    application/x-java-bean;version=1.3 Java Yes
    application/x-java-bean;version=1.3.1 Java Yes
    application/x-java-bean;version=1.4 Java Yes
    application/x-java-bean;version=1.4.1 Java Yes
    application/x-java-bean;version=1.4.2 Java Yes
    application/x-java-bean;jpi-version=1.4.2_02 Java Yes

    ====================================================================================================

    Also I can not compile Aplets although normal java and
    Swing-programs I can compile, no problem.

    To 'see' javac and java I have to add to my $PATH
    /usr/java.j2sdk1.4.2_02/bin

    Error when compiling:
    edward@linux:~/java> javac Simple.java
    Note: Simple.java uses or overrides a deprecated API.
    Note: Recompile with -deprecation for details.

    My questions:
    - Is the dis-functioning of the plugins and the
    not-being-able-to-compile-plugins related? (I think not, only
    coincidence, but I am just working with Java for 1 week now so knowledge
    is lacking here!)

    - How can I solve those problems, should there be added more directories
    to the path in order to be able to compile?

    Thanks in advance, Edward Hage


  • Next message: somebody: "How to read SSL certificates?"