Re: DBI requires 5.6.0 or 5.6.1?

Tim Bunce wrote:
On Fri, Jul 13, 2007 at 07:38:02PM -0500, Paul DuBois wrote:

Changes in DBI 1.33, 27th February 2003

NOTE: Future versions of the DBI *will not* support perl 5.6.0 or earlier.
: Perl 5.6.1 will be the minimum supported version.
Okay, but ...

Changes in DBI 1.38, 21th August 2003

NOTE: The DBI now requires perl version 5.6.0 or later.
(As per notice in DBI 1.33 released 27th February 2003)
Which contradicts the 1.33 section a bit.


Changes in DBI 1.49 (svn rev 2287), 29th November 2005

Change to require perl 5.6.1 (as advertised in 2003) not 5.6.0.

But says:

require 5.006_00;

$DBI::VERSION = "1.58"; # ==> ALSO update the version in the pod text below!

So I'm afraid I'm confused by this. What's the required version?

The gist is that 5.6.0 is broken in several ways that didn't directly
impact DBI, so I told people that "Perl 5.6.1 will be the minimum
*supported* version" (new emphasis). However, some old systems have 5.6.0
pre-installed so I let 5.6.0 be the minimum *required* version.

The comment you quoted for DBI 1.49 was a puzzle to me so I looked at
the relevant diff. Turns out to be another case of managing expectations:

-if ($] < 5.006001 && $^O ne 'darwin') {
- # we ignore scaring darwin users because they're stuck on 5.6.0 for now
+if ($] < 5.008000) {
warn qq{\a\a\a
- Version $] of perl will NOT BE SUPPORTED by future DBI releases.
- You will have to upgrade your perl or stop upgrading DBI.
- Perl version 5.6.1 will be the lowest version supported.
- Using perl $] you may notice some test warnings and two failures.
+ Perl versions below 5.6.1 are no longer supported by the DBI.
+ Perl versions 5.6.x may fail during installation with a complaint
+ about the use of =head3 in the pod documentation.
Press return to continue...

If someone tells me that the current DBI doesn't work with 5.6.0 then
I'll probably tweak the required version (or fix the problem).

Is this an issue for you or just curiosity?

Tim, thanks for clarifying.

I was wondering because it wasn't clear to me, in writing about DBI, how to
characterize what version of Perl a reader should have. I'll write that
5.6.0 is required but 5.6.1 is preferred.